OkMap forum
OkMap forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 OkMap Forum - English
 Projections and datum
 RT90 projection Sweden, calibration error

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
UserName:
Password:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailInsert Image Insert CodeInsert QuoteInsert List
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

   Insert image on imageshack.us
 Insert small zipped file as attachment (< 500 Kb)
 
Check here to subscribe to this topic.
   

T O P I C    R E V I E W
PeterHe Posted - 20/03/2012 : 01:32:09
I have failed using the Swedish projection RT90 2.5 Gon V 0:-15 to geo-reference a national map. The position for the map is about 100 km west of the correct location. I have tried (I think) all available projection alternatives filtering on the country Sweden. That includes RT90 7.5 and 5 Gon V (similar result). I also checked the datum and projection (list - preset projections and datum) from our national map supplier and the parameters seem correct:
<http://www.lantmateriet.se/templates/LMV_Page.aspx?id=4766&lang=EN>
Using a custom projection, the result was not better.
However, using a local conversion service found at:
<http://rl.se/rt90>
and inserting returned WGS84 coordinates (deg) in okmap it worked great.
What can be wrong?


Thanks,
Peter
15   L A T E S T    R E P L I E S    (Newest First)
okmap Posted - 03/04/2012 : 15:17:35
Peter, about projection name I've used official names of GeoRepository database (see at http://georepository.com/search/by-name/?query=sweden&include_world=on and click on "Projections (6)" tab).
OkMap has 2 setup buttons named "Map setup" and "Grid setup".
The first setups map datum and map projection through a wizard.
The first form of the wizard lists all known "predefined projection" (they are a combination of datum+projection). If you find your combination the wizard ends. If not, select "Customized projection" and the wizard continues with a datum selection and then with a projection selection.
This may be sufficient to calibrate a map.
The second button (grid setup) is to specify the datum and projection used to draw the metric grid on the map (normally it's the same of the map but I've encountered some russian maps where those was different). The "Grid setup" button also enables the "Alt" grid tab in the box coordinates so, if you want that OkMap draw the alternative (metric) grid or you want to use the "Alt" tab, you should copy (normally) the alternative grid same as map projection (there is a button to do this). I hope that this clears a complicated issue.
I apologize for my brutal English .
PeterHe Posted - 03/04/2012 : 13:21:19
Hi again,

Many thanks for your verification, I am really grateful for your efforts. I have now also found the actual problem: I thought alternative grid over-rode the map setup, but it didn't (I compared your map-file and mine - the projection was incorrect in mine).

The whole reason for the problem is the (what I find) somewhat confusing input dialogue, the principal steps are however easy to understand. I believe it would be much easier to always select datum/reference, projection and grid, using {\em identical} terminology everywhere. For instance change the two "map setup" and "grid setup" to three: "Datum setup", "Projection setup", "Grid setup", with a "help" containing brief information below all three. The datum or reference is then the reference information for what is the origin, rotations and the model shape of the earth. The projection describes how to flatten it out to print it on a planar surface. The grid is just the guiding lines on the map. Now, the datum and/or projection is selected in different places in a non-uniform way but with very similar names all containing RT90, RT90 0 Gon and RT90 2.5 Gon V. In the map-file I can find both RT90 O Gon as well as RT90 2.5 Gon V, which appears contradictory. Geographically, it appears I should use RT90 5 Gon V or perhaps RT90 7.5 Gon V - but that is only used for large scale maps.

Would it be possible to rearrange the input dialogue to be more 'logical'? At least make the alt grid option inactive as long as no alt grid has been selected (and some information how to do it...)? Sorry for all opinions but the handling is really important to avoid mistakes. I also understand that the standards for maps are mixed and confusing so it is not simple to construct the input dialogue.

Thanks again for an overall excellent program, I will make a donation shortly.


Best regards,
Peter
(Sorry for not responding earlier but I have been away for a few days...)




quote:
Originally posted by okmap

Hi Peter, I've received your map by email.
I've only changed the predefined projection to "RT90 0 gon" and nothing more.
Your georef points was good.
Now calibration seem ok.
1. Grid match on map very good
2. If you launch Utilities - Goole Earth (map + gpx) maps overlay perfectly with background (use transparency slider to check the goodness of overlapping).
This is the new .okm file:

Allegato : 6B_13.zip#9;1.32áKB

okmap Posted - 28/03/2012 : 08:51:15
Hi Peter, I've received your map by email.
I've only changed the predefined projection to "RT90 0 gon" and nothing more.
Your georef points was good.
Now calibration seem ok.
1. Grid match on map very good
2. If you launch Utilities - Goole Earth (map + gpx) maps overlay perfectly with background (use transparency slider to check the goodness of overlapping).
This is the new .okm file:

Allegato : 6B_13.zip#9;1.32 KB
okmap Posted - 26/03/2012 : 12:28:26
OkMap don't read zip file.
I tell you to use zipped file to upload to the forum.
Modify directly the file:
C:\Documents and Settings\<user>\Dati applicazioni\GianPaoloSaliola\OkMap\<version>\defs\datum.xml
Try to remove Bursa-Wolf parameters and retry to georeference your map. Tell me if this correct the issue.
However send me your map at mailto:info@okmap.org so I'll do some tests.
PeterHe Posted - 26/03/2012 : 09:53:00
Thanks, that explains why it did not update... It was no problem to find Datums.xml and to modify it. The question is how to 'zip' it and put it in the proper location. I am using CAM zip/unzip (http://www.camunzip.com/), will that create the correct zip-file for okmap? Also, since I could not locate any current zip-file, I guess 'zip' refers to some other operation on the Datums.xml file...
My O/S is Windows XP SP3.


Regards,
Peter



quote:
Originally posted by okmap

You should zip it first because server recognizes only few mime/type.
Which operating system have you?
The path I send you is for Windows 7.
For Windows XP your correct path is:
C:\Documents and Settings\<user>\Dati applicazioni\GianPaoloSaliola\OkMap\<version>\defs

okmap Posted - 25/03/2012 : 19:22:32
You should zip it first because server recognizes only few mime/type.
Which operating system have you?
The path I send you is for Windows 7.
For Windows XP your correct path is:
C:\Documents and Settings\<user>\Dati applicazioni\GianPaoloSaliola\OkMap\<version>\defs
PeterHe Posted - 25/03/2012 : 11:37:24
I have now tried to modify as suggested. However, from the list-datum the changes appears not to have been activated. I could not attached the Datums.xml file (some server problem?) either. So how to I force okmap to use the modified file? (Same instruction in the manual)


Regards,
Peter


quote:
Originally posted by okmap

Peter, please, make this test.
Modify datum.xml in C:\Users\<user>\AppData\Roaming\GianPaoloSaliola\OkMap\<version>\defs
and set to 0 the Bursa Wolf parameters (Rotation X,Y,Z and Scaling).
Then retry to georeference your map image (File - Modify - Setup parameters and press "Accept button") to recalculate georef coefficients.
This test will tell us if there is something of wrong in transformation algorithm.
Few datum use Bursa Wolf parameters so I don't have necessary received issues from other users.

okmap Posted - 23/03/2012 : 16:07:50
Peter, please, make this test.
Modify datum.xml in C:\Users\<user>\AppData\Roaming\GianPaoloSaliola\OkMap\<version>\defs
and set to 0 the Bursa Wolf parameters (Rotation X,Y,Z and Scaling).
Then retry to georeference your map image (File - Modify - Setup parameters and press "Accept button") to recalculate georef coefficients.
This test will tell us if there is something of wrong in transformation algorithm.
Few datum use Bursa Wolf parameters so I don't have necessary received issues from other users.
PeterHe Posted - 23/03/2012 : 15:53:48
I made a simple test to find adjusted false easting and northing settings. Picking two points separated 500 km north-south the deviations were (using okmap as a converter):
#1: E: -157.1 meter and N: -28.7 meter
#2 (500 km north of #1): E: -141.9 and N:-90.4
Hence, adjusting in this way appears to work locally (100 km perhaps).
Since the false eastings/northings should just be offsets this indicates that there is more than just an coordinate offset that is the problem. Perhaps there is something with the geoid rotations. That is, the translations/rotations "center*" and "rotation*" of the RT90 datum in okmap. Sorry for a silly question but did you put the numbers in manually (can any figure be incorrect)? It is strange since your source georepository gets the coordinates correctly. If the problem is in the projection algorithm, the problem should have occurred frequently for other users.

I know the projection involves a fair amount of mathematics. For ellipsoid there are no analytical expressions for the transformation/projection so Taylor expansions has to be used:
http://www.lantmateriet.se/upload/filer/kartor/geodesi_gps_och_detaljmatning/Rapporter-Publikationer/LMV-rapporter/BGR_Rapport_eng.pdf
I am simply guessing but could some reference point for the expansion be incorrect for RT90? That might lead to a slightly inaccurate calculation. Se especially sections 4.2 and page 27-table geocentric parameters where you can identify similar numbers to what you supplied. * However, there is a decrepancy, could that be it??? *
The accuracy stated is much better than the error I obtain...
I just need to find out what that table refers to.


Best regards,
Peter


quote:
Originally posted by okmap

Use "Customized projection" is a good practise when don't exists the relative predefined projection.
However if you have much maps to georeference consider the possibility to add your projection to the predefined projection xml file.
If your data is known in an ufficial repository send me and I'll add for you (please send me data and link of repository or web page).

okmap Posted - 23/03/2012 : 10:57:45
Use "Customized projection" is a good practise when don't exists the relative predefined projection.
However if you have much maps to georeference consider the possibility to add your projection to the predefined projection xml file.
If your data is known in an ufficial repository send me and I'll add for you (please send me data and link of repository or web page).
PeterHe Posted - 23/03/2012 : 10:32:39
With reference to the last link "georepository", the datum and grid/projection/coordinates am using should be RT90 2.5 Gon V. As I understand RT90 is the datum and 2.5 Gon V the projection, but the projection also appears to be built into the definition of RT90. The terminology is quite confusing, it should be one datum and one projection, period. Then there is also a SWEREF99/2.5 Gon V emulation. It has another reference ellipsoid /geoid (GRS80), hence a different datum, right? Whether RT90 or SWEREF is stated first is probably irrelevant for the problem here (see comparison below). I also looked at the parameters for the datum (in the same program). They appear to agree with the 'direct projection method' I referred to before:
http://www.lantmateriet.se/templates/LMV_Page.aspx?id=5197&lang=EN

There is also conversion table where 2.5 Gon is omitted (the reference I presume is equivalent to SWEREF):
http://www.lantmateriet.se/upload/filer/kartor/geodesi_gps_och_detaljmatning/Transformationer/SWEREF99_RT90_Samband/Transformationsparametrar_pdf.pdf

Comparison: I downloaded the conversion coordinate program found at georepository. The conversion agreed very well with www.rl.se, only the last digit differed slightly (cannot tell which is most accurate). I used RT90 2.5 Gon V as well as SWEREF99/2.5 Gon V emulation, the differences were around 0.000001 in both N and E (only last digit changed).

One thing I have not been able to verify is the Bessel 1841 displacements and rotation numbers, but I guess that is built into the Bessel 1841 definition which should be correct if is works on other places.

One temporary 'fix' to the problem might be to change the false easting and northing using a custom projection (Grid setup - Set alternate grid - Customized projection - RT90 - Parameters). Would you recommend that as a temporary solution? Should the same correction be applicable for the entire Sweden or just locally (range?)? Then I can use rl.se to find the difference, i.e. 'calibrate okmap' versus rl.se. I fully understand if you don't like this quick fix...


Best regards,
Peter


quote:
Originally posted by okmap

For RT90 I've used the same parameters as in the page www.eye4software.com/resources/datum/4124/" target="_blank">www.eye4software.com/resources/datum/4124/" target="_blank">http://www.eye4software.com/resources/datum/4124/.

<datum>
<name>RT90</name>
<idDatum>4124</idDatum>
<flagEnabled>true</flagEnabled>
<idEllipsoid>7004</idEllipsoid>
<ellipsoid>Bessel 1841</ellipsoid>
<rMajor>6377397.155</rMajor>
<rMinor>6356078.96281819</rMinor>
<invFlattening>299.1528128</invFlattening>
<flattening>0.00334277318217481</flattening>
<eccentricity>0.0816968312225267</eccentricity>
<eccentricitySec>0.0819708411520505</eccentricitySec>
<centerX>414.0978567149</centerX>
<centerY>41.3381489658</centerY>
<centerZ>603.0627177516</centerZ>
<rotationX>-0.8550434314</rotationX>
<rotationY>2.1413465185</rotationY>
<rotationZ>-7.0227209516</rotationZ>
<scaling>0</scaling>
</datum>

They should be correct.
See the page at link http://georepository.com/search/by-name/?query=rt90 and click "Projections" tab.
There are all projections used togheter RT90 datum.
See which of these refers to your map and tell me know.


okmap Posted - 22/03/2012 : 19:50:26
For RT90 I've used the same parameters as in the page http://www.eye4software.com/resources/datum/4124/.

<datum>
<name>RT90</name>
<idDatum>4124</idDatum>
<flagEnabled>true</flagEnabled>
<idEllipsoid>7004</idEllipsoid>
<ellipsoid>Bessel 1841</ellipsoid>
<rMajor>6377397.155</rMajor>
<rMinor>6356078.96281819</rMinor>
<invFlattening>299.1528128</invFlattening>
<flattening>0.00334277318217481</flattening>
<eccentricity>0.0816968312225267</eccentricity>
<eccentricitySec>0.0819708411520505</eccentricitySec>
<centerX>414.0978567149</centerX>
<centerY>41.3381489658</centerY>
<centerZ>603.0627177516</centerZ>
<rotationX>-0.8550434314</rotationX>
<rotationY>2.1413465185</rotationY>
<rotationZ>-7.0227209516</rotationZ>
<scaling>0</scaling>
</datum>

They should be correct.
See the page at link http://georepository.com/search/by-name/?query=rt90 and click "Projections" tab.
There are all projections used togheter RT90 datum.
See which of these refers to your map and tell me know.
PeterHe Posted - 21/03/2012 : 23:47:28
I just checked the difference between Okmap and rl.se by converting WGS84 coordinates in both and evaluating the difference between the Okmap 'alt' tab and rl.se's result (Okmap coordinates too small):
E: -157.1 meter
N: -28.7 meter
The differences were similar also for another point on the map.
There is actually some discussion of RT90 and errors of this order when converting from WGS84:
http://lists.maptools.org/pipermail/proj/2008-December/004164.html
http://www.lantmateriet.se/templates/LMV_Page.aspx?id=5197&lang=EN
http://www.lantmateriet.se/templates/LMV_Page.aspx?id=4953#xyzdiff
http://www.lantmateriet.se/upload/filer/kartor/geodesi_gps_och_detaljmatning/Transformationer/SWEREF99_RT90_Samband/Transformationsparametrar_pdf.pdf
http://www.fig.net/pub/fig2006/papers/ps05_03/ps05_03_04_engberg_lilje_0670.pdf

Perhaps this is helpful...

Regards,
Peter


quote:
Originally posted by okmap

mihermano has reason. The "Alt" tab in coordinates box refers to "Alternative projection" set by "Grid setup" button.
In other functions (outside a map environment) "Alt" tab in coordinates boxes refers to "Alternative grid" in Preferences - Grids page.
I've separated "map grid" from "alt grid" because there are some maps (eg Russian) that are projected with a projection (map projection) but the metric grid is drawn with another projection (grid projection).
Tell us if this is the origin of issue.

PeterHe Posted - 21/03/2012 : 22:19:51
Thanks a lot, see reply below. The datum in Sweden is RT90 and there are all the flavors you see in Okmap. We also have the SWEREF99 system. WGS84 is however normally used in all devices (mobile phones, GPS) you can buy here. As I understand though, WGS84 is just the datum and has no projection associated to it, so RT90 and WGS84 are not exactly comparable. Right? (I have limited experience of these systems. In principle fairly easy, but all different versions and incomplete formulations makes it hard to get it all right.)


Regards,
Peter



quote:
Originally posted by mihermano

Hi. An offset of 100 kilometres is very large. Is your Alternate grid set correctly in OkMap Preferences (Preferences>Grids>Set altern. grid)?

In my OkMap usage, the "Alt" tab is *not* equal *unless the correct setting is entered in Preferences as above, and I think a versatile option/function mainly for user information.

Is WGS84 a standard map datum for Sweden?



EeePC1001HA
OkMap V10.6.2

A journey of a thousand miles begins with a single step. - Lao Tzu/Confucius

PeterHe Posted - 21/03/2012 : 22:15:09
Hi,

Thanks a lot, it almost solved the issue! The error reduced from 100 km to about roughly 200 m, I think. Still not good for hiking though. Using the conversion facility at http://rl.se/rt90 I can adjust my RT90 X-Y coordinates in Okmap by adjusting the deg-decimal (first tab). Then I see that the RT90 coordinates are adjusted by a couple of hundred meters in both E and N. The map result using deg-decimal is as good as it can be. Something is still slightly wrong. I can also see that the grid is not matching very well (1 km separation), even though it is correctly lined up.

The are about 4-5 correct digits in Okmap, compared to rl.se converter. There is no reason why the accuracy should be poorer. In both Okmap and rl.se, try for instance the pair :
RT90 North: 6399000 <=> WGS84 57,670935░ N
RT90 East: 1299000 <=> WGS84 12,436115░ E
Datum/projection: RT90 2.5 GonV 0:-15
and you will see that the coordinates differ.

Any suggestion? Change the offsets in the RT90 datum (list-datum)???

(The logic in selecting the datum/proj in the grid setup is beyond my understanding though... Could some hint be added somewhere so other persons can avoid this mistake?)


Thanks again!
Regards,
Peter


quote:
Originally posted by okmap

mihermano has reason. The "Alt" tab in coordinates box refers to "Alternative projection" set by "Grid setup" button.
In other functions (outside a map environment) "Alt" tab in coordinates boxes refers to "Alternative grid" in Preferences - Grids page.
I've separated "map grid" from "alt grid" because there are some maps (eg Russian) that are projected with a projection (map projection) but the metric grid is drawn with another projection (grid projection).
Tell us if this is the origin of issue.


OkMap forum © 2018 OkMap Go To Top Of Page
Powered By: Snitz Forums 2000 Version 3.4.07